Performance degradation due to AWS outage

Incident Report for Cydar Ltd.

Resolved

Cydar Maps is now working normally.
Posted Oct 21, 2025 - 11:29 BST

Update

We are continuing to investigate this issue.
Posted Oct 21, 2025 - 00:38 BST

Investigating

Cydar Maps is being affected by a widespread AWS outage. All functionality is available, but you may experience performance degradation in some areas.
Posted Oct 20, 2025 - 17:54 BST
This incident affected: Cydar EV US Production (Cydar at your desktop, Cydar in the operating room).